Floating Static Route

1. Introduction to Floating Static Routes

🔍 What is a Floating Static Route?

A floating static route is a backup static route configured with a higher Administrative Distance (AD) than the primary route. This ensures the floating static route is only used when the primary route is unavailable.

By having a higher AD, the floating static route is not present in the routing table unless the primary route fails!

💡 Why it matters: Floating static routes provide redundancy, helping maintain connectivity during link or route failures.

For example, R1 can prioritize an OSPF route (AD 110) while using a static route (AD 130) as a backup if the OSPF route fails.

Configure Floating Static Route

2. Key Concepts

🔍 Administrative Distance (AD)

Administrative Distance (AD) is a measure used by routers to determine the trustworthiness of a route. It plays a critical role in deciding which route to include in the routing table when multiple paths to the same destination exist.

  • What is AD?
    AD is a numerical value assigned to routes based on their source (static routes, OSPF, RIP). Routes with lower AD values are preferred over those with higher values.

🔍 Default Administrative Distance Values

Route SourceAdministrative Distance
Directly Connected0
Static Route1
EIGRP (Internal)90
OSPF110
RIP120
Floating Static RouteCustom

Key Point: The default AD of a static route is 1. By manually increasing it to 130, the route becomes a floating static route that acts as a backup if one route exists to the destination with a lower AD.

3. Configuration of Floating Static Routes

🛠️ Prerequisites

To implement redundancy in the network to reach the network 192.168.3.0/24, we will configure a floating static route. This backup route activates only when the primary route, provided by a dynamic routing protocol like OSPF, becomes unavailable.

🔹 Primary Route Configuration with OSPF

In this example, the primary route is established using OSPF between R1 and R2, enabling communication with the 192.168.3.0/24 network.

Configure Floating Static Route 1

Before configuring the floating static route, ensure OSPF is properly set up to act as the primary routing protocol.

🔹 Configuration for R1 (OSPF):

R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0

🔹 Configuration for R2 (OSPF):

R2(config)# router ospf 1
R2(config-router)# network 192.168.1.0 0.0.0.255 area 0
R2(config-router)# network 192.168.3.0 0.0.0.255 area 0

🔹 Backup Route Configuration with a Floating Static Route

The floating static route will serve as a backup for the OSPF route. This is achieved by assigning the static route a higher Administrative Distance (AD) than OSPF’s default of 110.

🔹 Configuration for R1 (Floating Static Route):

R1(config)# ip route 192.168.3.0 255.255.255.0 192.168.2.2 130

Explanation:

  • Destination Network: 192.168.3.0/24
  • Next-Hop IP Address: 192.168.2.2 (interface to R3)
  • Administrative Distance: 130 (higher than OSPF’s 110)

This ensures that the static route will not appear in the routing table unless the OSPF route via R2 becomes unavailable.

4. Simulate Failover

🔹 Verify OSPF Routes

Now we are going to check the OSPF routes on R1 to ensure the primary route is active.

R1# show ip route
O     192.168.3.0/24 [110/2] via 192.168.1.2, 00:00:10, GigabitEthernet0/0
      192.168.1.0/24 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is directly connected, GigabitEthernet0/1

Observation: The OSPF route to 192.168.3.0/24 is active, with an Administrative Distance (AD) of 110.

🔹 Verify the Floating Static Route

Our Floating Static Route is present in the configuration but not active in the routing table.

R1# show running-config | include ip route
ip route 192.168.3.0 255.255.255.0 192.168.2.2 130

Observation: The floating static route does not appear in the routing table because the OSPF route is preferred.

🔹 Simulate Failover (Primary Route Failure)

Disable the link between R1 and R2 to simulate a failure of the OSPF route.

R2(config)# interface GigabitEthernet0/0
R2(config-if)# shutdown
Simulate Failover Static Floating Route

Re-check the routing table on R1 after disabling the OSPF link.

R1# show ip route
S     192.168.3.0/24 [130/0] via 192.168.2.2
      192.168.2.0/24 is directly connected, GigabitEthernet0/1

Observation: The OSPF route is removed from the routing table due to the link failure, and the floating static route becomes active to maintain connectivity to 192.168.3.0/24.

🔹 Restore the Primary Route

Re-enable the OSPF link on R2 to restore the primary route.

R2(config)# interface GigabitEthernet0/0
R2(config-if)# no shutdown

Verify the routing table on R1 after restoring the OSPF link.

R1# show ip route
O     192.168.3.0/24 [110/2] via 192.168.1.2, 00:00:10, GigabitEthernet0/0
      192.168.1.0/24 is directly connected, GigabitEthernet0/0
      192.168.2.0/24 is directly connected, GigabitEthernet0/1

Observation: The OSPF route (AD 110) is restored as the primary route, and the floating static route (AD 130) is no longer active in the routing table.

📢 Next Steps: In the next course, we will explore default static routes and their configurations!