LACP EtherChannel

1. Introduction to LACP EtherChannel

In this course, we will go step by step through the configuration of LACP EtherChannel. Unlike Static EtherChannel, which requires manual configuration, LACP (Link Aggregation Control Protocol) allows dynamic negotiation between switches, making link aggregation more flexible and fault-tolerant.

Interfaces are dynamically grouped using active or passive modes. This configuration will also include setting up interfaces as trunks and allowing VLAN 50 on the trunk.

Prerequisites for Configuration 🛠️

Before starting, ensure the following conditions are met:

Interface Consistency: All interfaces in the EtherChannel must have the same speed, duplex, and interface type.

VLAN and Trunking: For Layer 2 links, interfaces must be in the same VLAN or have identical trunk settings.

Active Links: Ensure that each physical link is operational.

EtherChannel Caracteristics 1

For this configuration, we will use GigabitEthernet interfaces in full-duplex mode, and we will allow VLAN 50 on the trunk link.

2. Steps to Configure LACP EtherChannel

Here, we will configure EtherChannel using the open standard Link Aggregation Control Protocol (LACP), which is defined by IEEE 802.3ad. LACP allows the bundling of multiple physical links into one logical link, providing redundancy and increased bandwidth.

We’ll configure the ports to use LACP, set them as trunks, and allow VLAN 50 on the trunk.

Configuring EtherChannel with LACP

🔹 Enter Interface Configuration Mode

1. Enter Interface Configuration Mode

First, we must select the interfaces that will participate in the EtherChannel on each switch.

  • On SW1:
SW1(config)# interface range g0/0 - 1
  • On SW2:
SW2(config)# interface range g0/0 - 1

Note: Using the interface range command allows configuring multiple interfaces at once, saving time

🔹 Set LACP Mode

LACP supports two modes:

  • Active Mode → The switch actively initiates LACP negotiation.
  • Passive Mode → The switch waits for LACP negotiation requests.
Configuring EtherChannel with LACP 1

For this configuration:

  • SW1 will use Passive Mode, waiting for LACP negotiation.
  • SW2 will use Active Mode, initiating LACP negotiation.

SW1 (Passive Mode):

SW1(config-if-range)# channel-group 1 mode passive

SW2 (Active Mode):

SW2(config-if-range)# channel-group 1 mode active

Note: After executing this command, a logical interface called Port-Channel 1 (Po1) is created on each switch.

🔹 Configure Trunk Mode and VLAN

Once the EtherChannel is established, we need to configure Port-Channel 1 as a trunk and allow VLAN 50.

  • SW1:
SW1(config)# interface port-channel 1 
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk 
SW1(config-if)# switchport trunk allowed vlan 50

SW2:

SW2(config)# interface port-channel 1 
SW2(config-if)# switchport trunk encapsulation dot1q
SW2(config-if)# switchport mode trunk 
SW2(config-if)# switchport trunk allowed vlan 50

Explanation:

  • The switchport trunk encapsulation dot1q command ensures 802.1Q encapsulation for VLAN tagging.
  • The switchport mode trunk command enables trunk mode on the Port-Channel.
  • The switchport trunk allowed vlan 50 command ensures that VLAN 50 is permitted to pass through the trunk.

3. Verifying the Configuration

Now that LACP EtherChannel is configured, we must verify that:

1️⃣ The EtherChannel is successfully formed and operational.
2️⃣ Trunking is correctly configured and VLAN 50 is allowed.

Verify the EtherChannel Formation 2

🔍 Verify EtherChannel Formation

To check if the EtherChannel has been successfully formed, use the following command on each switch:

  • SW1:
SW1# show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone  S - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use       N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Group  Port-channel  Protocol    Ports
------ ------------- ----------- ----------------------------------------------
1      Po1(SU)       LACP        Gi0/0(P) Gi0/1(P)

Po1(SU) → Confirms that Port-Channel 1 is active in Layer 2 mode (S) and is up (U).

LACP protocol is displayed → Verifies that the Link Aggregation Control Protocol (LACP) is used for dynamic link aggregation.

Gi0/0(P) Gi0/1(P) → These interfaces are successfully bundled into Port-Channel 1.

Now, repeat the same command on SW2:

  • SW2:
SW2# show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone  S - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use       N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Group  Port-channel  Protocol    Ports
------ ------------- ----------- ----------------------------------------------
1      Po1(SU)       LACP        Gi0/0(P) Gi0/1(P)

🎯 The same output on both switches confirms that the LACP EtherChannel is correctly established between them.

🔍 Verify the Trunk Configuration

Now, let’s verify that Port-Channel 1 is configured as a trunk and that VLAN 50 is allowed.

Use the following command:

  • SW1:
SW1# show interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port        Vlans allowed on trunk
Po1         50

802.1q encapsulation → Confirms that trunking is enabled with 802.1Q VLAN tagging.
VLAN 50 is allowed → Ensures that traffic for VLAN 50 can pass through Port-Channel 1.

Repeat the command on SW2:

  • SW2:
SW2# show interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port        Vlans allowed on trunk
Po1         50

🎯 The same output confirms that trunking is correctly configured on both switches and that VLAN 50 is allowed.

4. Conclusion

The LACP EtherChannel configuration is now successfully completed!

Port-Channel 1 (Po1) aggregates two physical interfaces into one logical link.
Trunk mode is properly configured, allowing VLAN 50 traffic.
LACP ensures dynamic negotiation, improving redundancy and load balancing.

Verify the EtherChannel Formation 3

⚠️ Key Takeaways:

  • LACP (IEEE 802.3ad) dynamically forms EtherChannels, reducing misconfiguration risks.
  • If the EtherChannel is not forming, check interface consistency (speed, duplex, VLAN).
  • Trunking should be properly set on the Port-Channel to ensure VLAN communication.

📢 Next Lesson: We will explore PAgP EtherChannel, a Cisco-proprietary alternative to LACP for link aggregation! 🚀